Jump to content
CMSTOOLS.ru - форум поддержки и развития CMS

Как можно исправить работу видео?


Recommended Posts

Привет всем пользователям! Скажите, пожалуйста, как можно излечить работу модуля видео, чтобы он подгружал видео с ютуба?
Есть какие-то способы решения, или уже все - безуспешно, чинить нету смысла?

Буду благодарен за адекватный ответ

Screenshot_389.png

Link to comment
Share on other sites

4 часа назад, vadymholunha сказал:

Привет всем пользователям! Скажите, пожалуйста, как можно излечить работу модуля видео, чтобы он подгружал видео с ютуба?
Есть какие-то способы решения, или уже все - безуспешно, чинить нету смысла?

Буду благодарен за адекватный ответ

Screenshot_389.png

Немного изменить js для подгрузки через протокол https

Link to comment
Share on other sites

13 часов назад, timbios сказал:

 

Не хочу огорчать, но данный метод с ютубом уже не работает. Было сделано всё по инструкции, но пишет, что неправильно. Скрины прилагаются

Screenshot_397.png

Screenshot_398.png

Link to comment
Share on other sites

14 минут назад, vadymholunha сказал:

Не хочу огорчать, но данный метод с ютубом уже не работает. Было сделано всё по инструкции, но пишет, что неправильно.

ссылка в коде http://www.youtube.com/oembed?url=https://www.youtube.com/watch?v='.$exp_x[0].'&format=xml

ведет на редирект 307. замени http на https.

А лучше переписать.

Link to comment
Share on other sites

Не прокатило.  Заменил с http:// на https://, и никакого результата

Но заметил вот что. Обычно, когда ссылку не вводишь, то не высвечивается кнопка "Готово". После ввода ссылки должно же высвечивать название, описание к видео и кнопка "Готово"

На скриншоте отчётливо видно, что никаких других полей нет, пишет, что сервис не поддерживается, хотя кнопка "Готово" присутствует, хотя не должна, если ошибка

При её нажатии высвечивает вот что (скрин 2)

Screenshot_24.png

Screenshot_25.png

Link to comment
Share on other sites

@vadymholunhaСо стороны ютуба и Vimeo все работает без изменений, видео будет работать только через https. Сервисы  Smotri и RuTube работать не будут из-за флеша. 

Чтобы  просто работало - достаточно поменять протокол. В  лучшем случае в место fopen, лишних регулярок и xml использовать file_get_contents и json так-же поведения кнопки "Готово" не сложно сделать.

Link to comment
Share on other sites

2 часа назад, KirKMS сказал:

Вот пользуйся. Ещё вчера хотел выложить, но мне было лень :haha:

 

Спасибо!!! +100 тебе в копилку. Видео теперь работает, оно добавляется, но возникла другая проблема. Почему-то адрес дублируется, в последствии чего не отображается картинка (скрин 3)

Screenshot_407.png

Screenshot_408.png

Screenshot_409.png

Link to comment
Share on other sites

1 час назад, vadymholunha сказал:

Спасибо!!! +100 тебе в копилку. Видео теперь работает, оно добавляется, но возникла другая проблема. Почему-то адрес дублируется, в последствии чего не отображается картинка (скрин 3)

Screenshot_407.png

Screenshot_408.png

Screenshot_409.png

Версию php измени.

Link to comment
Share on other sites

16 часов назад, vadymholunha сказал:

Не прокатило.  Заменил с http:// на https://, и никакого результата

Но заметил вот что. Обычно, когда ссылку не вводишь, то не высвечивается кнопка "Готово". После ввода ссылки должно же высвечивать название, описание к видео и кнопка "Готово"

На скриншоте отчётливо видно, что никаких других полей нет, пишет, что сервис не поддерживается, хотя кнопка "Готово" присутствует, хотя не должна, если ошибка

При её нажатии высвечивает вот что (скрин 2)

Screenshot_24.png

Screenshot_25.png

Хм. У меня прокатило. По сути, способ от KirKMS- то же самое.
Кстати, как добавлять плюс в репу?

Link to comment
Share on other sites

Исправил, но почему-то внезапно при нажатии "Добавить видеозапись" перекидывает на главную страницу, хотя по идее должно открываться окно для ввода ссылки. Что на этот раз мной сделано не так?

Link to comment
Share on other sites

8 часов назад, vadymholunha сказал:

Исправил, но почему-то внезапно при нажатии "Добавить видеозапись" перекидывает на главную страницу, хотя по идее должно открываться окно для ввода ссылки. Что на этот раз мной сделано не так?

Возможно где-то функция не прописана по открытию окна

Link to comment
Share on other sites

9 часов назад, vadymholunha сказал:

Исправил, но почему-то внезапно при нажатии "Добавить видеозапись" перекидывает на главную страницу, хотя по идее должно открываться окно для ввода ссылки. Что на этот раз мной сделано не так?

Наверное в js не поставил запятую. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...