Jump to content

Recommended Posts

Хэш теги. не работают хэштеги в сборке MixNet.

Сделал все по инструкции 

 

1. Открываешь файл wall.php ( /system/classes/ ).
2. Заменяешь

$tpl->set('{text}', stripslashes($row_wall['text']));


на

$msg = stripslashes($row_wall['text']);
$pat = array('/#(\w+)/', '/@(\w+)/');
$rep = array('#$1','@$1');
$new_msg = preg_replace($pat, $rep, $msg);
$tpl->set('{text}', $new_msg);

post-126-0-01329000-1441654146_thumb.png

Edited by iKill

Share this post


Link to post
Share on other sites

Хэш теги. не работают хэштеги в сборке MixNet.

Сделал все по инструкции 

 

1. Открываешь файл wall.php ( /system/classes/ ).

2. Заменяешь

$tpl->set('{text}', stripslashes($row_wall['text']));

на

$msg = stripslashes($row_wall['text']);

$pat = array('/#(\w+)/', '/@(\w+)/');

$rep = array('#$1','@$1');

$new_msg = preg_replace($pat, $rep, $msg);

$tpl->set('{text}', $new_msg);

Лол, потому что ты ничего, по сути, этими регулярками и не сделал. Текст заменяется сам на себя, а не на ссылку.

Share this post


Link to post
Share on other sites

Тема в помощь.

Я все сделал как там написано. так же поиск по новостям работает php 5.5

А все равно хэш теги отображаются как текст  

Share this post


Link to post
Share on other sites

Лол, потому что ты ничего, по сути, этими регулярками и не сделал. Текст заменяется сам на себя, а не на ссылку.

И как сделать помоги

Share this post


Link to post
Share on other sites

Все исправил


Тему можно закрывать


Решил методом перезалития и заново вставил код только от сюда


 


И все сразу заработало


Share this post


Link to post
Share on other sites

 

Все исправил

Тему можно закрывать

Решил методом перезалития и заново вставил код только от сюда

 

И все сразу заработало

 

Т.е. тема помогла?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×