Jump to content

Recommended Posts

Фича AvAgent. (Авки агентов)

Инструкция:

 

1. Для начала установите модуль "Агенты #1 #2 #3"

2. Зайдите в support.php и там найдите: (там 2 таких же кода. Го в обеих.)


    $tpl->load_template('support/answer.tpl');

3. Ниже в этом же коде найдите

$tpl->set('{ava}', '{theme}/images/support.png');

и замените его значение на


if(file_exists('./uploads/agent_ava/'.$row_answer['agent_id'].'.png'))

{

$tpl->set('{ava}', '/uploads/agent_ava/'.$row_answer['agent_id'].'.png');

}else{

$tpl->set('{ava}', 'http://vk.com/images/support_budda2.png');

} 

4. В папке uploads создайте папку agent_ava и загрузите туда пару изображений с размером 50x50. Называйте файлы так ID_Агента.png

то есть, если ID агента 1, то пишем название изображения 1.png .

Теперь у каждого агента своя ава.

Автор: TODD WENJIRO

ukizlg-dzUA.jpg

 

Не откажусь от rep_up.png

 

Edited by TODD WENJIRO
Для рекламы есть соответствующие темы...
  • Upvote 3
  • Downvote 1

Share this post


Link to post
Share on other sites

А вообще все началось с того, что один человек попросил этот мод у меня, но мне было лень объяснять ему что к чему у меня было сделано (условие немного другое) и я ему что-то продиктовал такое... Это попало сюда, потом тему удалили, и наконец WolFox с viiprogrammer' ом допилили это дело)

Share this post


Link to post
Share on other sites

А вообще все началось с того, что один человек попросил этот мод у меня, но мне было лень объяснять ему что к чему у меня было сделано (условие немного другое) и я ему что-то продиктовал такое... Это попало сюда, потом тему удалили, и наконец WolFox с viiprogrammer' ом допилили это дело)

:)

Edited by WolFox

Share this post


Link to post
Share on other sites

Я вообще сделал чтобы через админку можно было агенту id сменить и аву, но это очень криво работает, но я пытаюсь доделать

Share this post


Link to post
Share on other sites

Отписывайтесь, кто ставил. :)

Я поставил модуль, теперь не работает как перехожу в сайт/support  перехожу и ничего не происходит 

Share this post


Link to post
Share on other sites

Я поставил модуль, теперь не работает как перехожу в сайт/support  перехожу и ничего не происходит 

Проверь правильность установки модуля, у меня все отлично идет. Если ты перезагрузишь страницу  в /support, то должно выйди 500 ошибка. Если вышла ошибка, то что-то ты неправильно сделал в support.php

 

2. Зайдите в support.php и там найдите: (там 2 таких же кода. Го в обеих.)

    $tpl->load_template('support/answer.tpl');

3. Ниже в этом же коде найдите {ava} и замените его значение на 

if(file_exists('./uploads/agent_ava/'.$row_answer['agent_id'].'.png'))

{

$tpl->set('{ava}', '/uploads/agent_ava/'.$row_answer['agent_id'].'.png');

}else{

$tpl->set('{ava}', 'http://vk.com/images/support_budda2.png');

} 

Share this post


Link to post
Share on other sites

Проверь правильность установки модуля, у меня все отлично идет. Если ты перезагрузишь страницу  в /support, то должно выйди 500 ошибка. Если вышла ошибка, то что-то ты неправильно сделал в support.php

 

 

2. Зайдите в support.php и там найдите: (там 2 таких же кода. Го в обеих.)

    $tpl->load_template('support/answer.tpl');

3. Ниже в этом же коде найдите {ava} и замените его значение на 

if(file_exists('./uploads/agent_ava/'.$row_answer['agent_id'].'.png')){$tpl->set('{ava}', '/uploads/agent_ava/'.$row_answer['agent_id'].'.png');}else{$tpl->set('{ava}', 'http://vk.com/images/support_budda2.png');}

Да, ошибка 500. Скинь мне какой должен быть текст или файл support.php уже с этим. Я просто не понимаю, что к чему

Share this post


Link to post
Share on other sites

Скорее и без него справиться можно.

насчет этого не уверен, может нужен, а может и нет

Share this post


Link to post
Share on other sites

Вывести бы это в админку...

Не в силах еще такое делать

Share this post


Link to post
Share on other sites

Скорее и без него справиться можно.

не, Нельзя... Уже тестил, там нужен ID агента, а он идет по модулю "1, 2, 3"

Share this post


Link to post
Share on other sites

Любой каприз за ваши деньги

хех... как тут лайк поставить без rep_up.png ?

Share this post


Link to post
Share on other sites

я всё сделал по инструкции и ничего не работает нет никаких цифр вообще и до этого не было крч их нет помогите

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×